Slow response time between Billing and Application
Incident Report for Orbital Shift
Resolved
Our Billing Portal is now fully functional and users should not experience any remaining latency issues. We apologize for any inconvenience and thank you for your patience.
Posted Sep 18, 2017 - 18:58 MDT
Investigating
We are experiencing slow response times between our Application and the Billing Portal. Users may experience longer than usual load time, and in some cases may time out. We continue to work closely with our provider to improve the response times. If you experience a page time out, please contact support@orbitalshift.com so that we may better assist. We apologize for any inconvenience this may have caused.
Posted Sep 18, 2017 - 16:30 MDT