Updating Credit Card Portal erroring
Incident Report for Orbital Shift
Resolved
Our credit card updating Billing Portal page has been updated and is now fully functional. We are sorry for any inconvenience this may have caused.
Posted Sep 07, 2017 - 05:13 MDT
Identified
Our Billing Portal handling credit card updates is currently down for the time being. We hope to have an update soon so that accounts may be updated.
Posted Sep 06, 2017 - 17:15 MDT