Major Internet Service Provider Outage
Incident Report for Orbital Shift
Resolved
We have reports of improved internet connectivity. We will continue to be aware of this matter, but will mark this issue as resolved. Thank you for your patience.
Posted Nov 06, 2017 - 15:47 MST
Monitoring
We are actively monitoring reports of a major Internet Service outage. Users may experienced longer than expected application load times and in some cases web page time outs. We will continue to monitor as this situation progresses. Thank you for your patience.
Posted Nov 06, 2017 - 13:01 MST