Punch Clock App: frequent "connection error" messages displayed when punching in.
Incident Report for Orbital Shift
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 15:16 MDT
Update
Our production servers are running without issues that affected the Punch Clock application. We will continue to monitor for recurrences.

Thank you.
Posted May 30, 2020 - 10:37 MDT
Update
Orbital Shift Engineering has identified an issue on a production server affecting performance of our Punch Clock mobile application. Errors should be residing. We continue to monitor any issues coming from the Punch Clock application.
Posted May 29, 2020 - 19:42 MDT
Investigating
We have received reports of the Punch Clock App - available from the Google Play Store and Apple iOS App Store - receiving frequent "connection error" messages while trying to submit clock station credentials to clock in. We are currently investigating the issue and will provide updates when the issue has been diagnosed.

Desktop and employee applications are currently unaffected, including web-based Clock Station functionality.

We apologize for any inconvenience.
Posted May 29, 2020 - 18:35 MDT
This incident affected: Mobile Apps.